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Abstract This user manual describes the TEA190x demonstration kit. The TEA190x
demonstration kit includes software to view and change the configuration of
the TEA190x. The software also shows live data, such as USB-PD messages,
bus voltage, and current. The software is called Teo (TEA190x evaluation
overdrive). It incorporates a graphical user interface (GUI) and several
libraries to communicate with the TEA190x family and monitor USB-PD traffic.
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Table 1. Revision history
Rev Date Description

v.2 20181116 second issue

Modifications: • The text has been updated throughout the document.
• The graphics have been updated throughout the document.

v.1 20170223 first issue
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1 Introduction

Warning

The non-insulated high voltages that are present when operating this product,
constitute a risk of electric shock, personal injury, death and/or ignition of fire.
This product is intended for evaluation purposes only. It shall be operated in a
designated test area by personnel qualified according to local requirements and
labor laws to work with non-insulated mains voltages and high-voltage circuits. This
product shall never be operated unattended.

This user manual describes the TEA190x family demonstration kit. The TEA190x
demonstration kit includes software to view and change the configuration of the
TEA190x. The software also shows live data, such as USB-PD messages, bus voltage,
and current. The software is called Teo (TEA190x evaluation overdrive, second
generation) and incorporates a graphical user interface (GUI) and several libraries to
communicate with the TEA190x and monitor USB-PD traffic.

Screen pictures may differ due to small software upgrades. If major upgrades occur, this
document is updated as well.
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2 Safety warning

The TEA190x is AC mains voltage powered. Avoid touching the board while it is
connected to the mains. An isolated housing is obligatory when used in uncontrolled,
non-laboratory environments. Galvanic isolation from the mains phase using a fixed or
variable transformer is always recommended. Figure 1 shows the symbols on how to
recognize these devices.

019aab173 019aab174

a. Isolated b. Not isolated

Figure 1. Isolation symbols
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3 Kit content

The TEA190x demonstration kit contains the following items:

• Demo board: A complete USB-PD source device
• UTC: A monitoring and sink device.
• Teo: Configuration and monitoring software for Microsoft Windows
• A type-C male-male cable: Connects UTC with the TEA190x.
• A type-B to micro-B USB cable: Connects UTC to a PC.
• A USB-OTG adapter: For upgrading the UTC firmware.
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a. TEA190x demo board b. UTC - USB-PD interface

c. Teo - PC software

Figure 2. TEA190x demonstration kit contents

Note: Several demo boards with different configurations exist. The picture shown in
Figure 2 may differ from the board in the demo kit.
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3.1 Other requirements

The demo board is preconfigured. It works out of the box. Teo runs on a PC with
Microsoft Windows. The demo board configuration can be changed. To change the
configuration, Teo is required. If the evaluation of the TEA190x is done with a USB-PD
sink, a number of options are available.

• Use UTC as a USB-PD sink. Teo configures UTC to act as a USB-PD sink. The
communication between TEA190x and UTC is shown in Teo. Optionally, a load (either
an electronic or resistive one) can be connected to UTC and draw current from the
TEA190x.

• Connect a USB-PD sink and use UTC to monitor the communication between sink and
TEA190x. Teo shows the USB-PD messages from and to the TEA190x.

• Connect a USB-PD sink and use external protocol analyzers to monitor the
communication between sink and TEA190x. Teo can still be used to change the
configuration of the TEA190x.

3.2 Compatibility

Teo is available for Windows 7, Windows 8, Windows 8.1, and Windows 10. 64-bit and
32-bit versions are supported.
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4 Quick start

This section provides the information to get started as quickly as possible. It does not
replace other information elsewhere in this document. Read the remainder to get the
most out of the demonstration kit.

4.1 Requirements

• To get the board working:
– TEA190x demo board (TEA190x demonstration kit)
– An AC mains power source, 110 V to 240 V (AC), 50 Hz to 60 Hz
– A set of wires for connection to the AC mains power source

• To change settings of TEA190x:
– Teo, PC software for TEA190x (TEA190x demonstration kit)
– One of the TEA190x data sheets (TEA190x demonstration kit)
– A PC running Microsoft Windows 7 or higher

• To monitor the TEA190x:
– Preferred device to connect with TEA190x, or
– A simulated sink such as UTC and Teo (TEA190x demonstration kit), or
– A lab with the required equipment

4.2 Before installing the PC software for the TEA1905

• Leave the demo board disconnected for now.
• Leave UTC disconnected for now.

Windows installs driver packages for both hardware interfaces. When the hardware
interfaces are plugged into one of the USB ports for the first time, the drivers are installed
automatically.
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4.3 Installing the PC software

• While installing the PC software, leave UTC disconnected.
• Run the installer wizard “Install_Teo_x_y_z.exe”. X, y, and z indicate the version

number of Teo.
• Follow the instructions of the installer wizard.

Two sets of drivers are installed. During the installation, messages may appear on the
screen asking to trust an unknown publisher. To continue the drivers initialization, confirm
by clicking "Yes".

In most cases, the drivers are installed instantaneously. However, sometimes a reboot
may be required. If a reboot is required, a message appears on the screen. Reboot your
PC before continuing with the next step.

4.4 Connecting the demo board to the PC

Connect UTC to the PC with the supplied USB cable. Connect the demo board to UTC
with the supplied type-C cable.

Teo recognizes UTC and lets you configure UTC to be used as a USB-PD sink or
USBPD Sniffer.

As a safety precaution, use a type-C cable to connect the TEA190x with a device. Plug
the type-C cable into the TEA190x board before supplying the mains power source.
Use the other end to connect a device. In this way, the high voltages on the board are
avoided.

Note: Even after disconnecting the charger from the mains supply, the large capacitor
keeps it charged with a high voltage for hours.

4.5 How to use the software

The software, Teo, shows a number of tabbed pages of controls:

• Basic: Always visible
• Advanced: Always visible
• Protection: Always visible
• Extended SrcCaps: Visible when USB-PD 3 is supported
• Sink or sniffer: Only visible when UTC is connected

The last tabbed page, Sink, or Sniffer, is designed for UTC. If UTC is connected, Teo
configures UTC to be used as a USB-PD sink or as a USB-PD sniffer. By default, UTC
boots in sniffer mode. See Section 5.2, for more information about UTC. If UTC is
disconnected, the last tab is hidden.

With the first four pages, changes can be made to the configuration of the TEA190x. If a
connection via UTC exists, the changes can be written and stored.

When the configuration is changed, the TEA190x must be restarted for those changes to
take effect. The "Soft restart" button on the Basic page restarts the TEA190x.

The requested voltage and current can be changed on the Sink tab. A hard reset or
soft reset can be performed. When a new voltage request has been inserted, press
Enter or Tab to cause the change to take effect. Clicking one of the PDOs, requests the
corresponding voltage.
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Captured USB-PD messages between the TEA190x and the USB-PD sink are listed on
the Sniffer tab.

If Teo fails to recognize the demo board, choose Scan interfaces from the Options
menu, to have Teo look again for known interfaces. Select the desired interface from the
Interface menu under Options.

When an interface is selected, Teo attempts to set up a connection with the TEA190x. If
the connection setup is successful, Teo reads all settings from the MTP memory.
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5 Hardware

The TEA190x demonstration kit incorporates a fully operational USB-PD source. It also
contains UTC, a peripheral device to change and monitor the behavior of the TEA190x.

5.1 The TEA190x demo board

The TEA190x demo board has a primary and secondary supply. The primary side is
connected to a mains source from 110 V (AC) to 240 V (AC) with wires. The frequency is
50 Hz or 60 Hz (see one of the TEA190x data sheets for the complete specification).

The secondary stage delivers power through a USB type-C female connector.

a. Type-C

b. Mains

Figure 3. TEA1905 demo board

Note: The board in the demonstration kit may look different from the pictures shown in
Figure 3.
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5.2 UTC

UTC (USB-PD Type-C controller) includes a micro-USB receptacle, a male type-C
connector, and a female type-C connector. The micro-USB receptacle can be connected
to a type-B connector on the PC with the cable supplied.

UTC receives operating power and communicates with Teo via the micro-USB
connection. In essence, the only difference between the two type-C connectors is the
gender. It allows UTC to be connected between a USB-PD source and sink.

UTC has access to the CC lines, can monitor and inject USB-PD messages, and
measures voltage and current on Vbus.

UTC operates in two different modes:

• Sink
• Sniffer

5.2.1 Sink mode

In sink mode, UTC acts as a USB-PD sink. It responds to a source being attached or
detached, just like a normal USB-PD sink does. UTC negotiates a contract and sends the
messages and state changes to Teo.

5.2.2 Sniffer mode

In sniffer mode, UTC ‘sits’ in the middle. It is invisible to both the TEA190x and the USB-
PD sink. USB-PD messages from/to the TEA190x are captured and sent to Teo.
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6 Software

The demonstration kit includes software to view and change the configuration of
TEA190x. The software also shows live data, such as USB-PD messages, bus voltage,
and current. The software is called TEA190x evaluation overdrive (Teo). To communicate
with TEA190x and monitor USB-PD traffic, it includes a graphical user interface (GUI)
and several libraries.

6.1 Installation

Teo, its libraries, and drivers are installed with a single installation wizard.

When the installation wizard is launched, the Windows user account control may ask if
you trust the application from an unknown publisher (see Figure 4). Click Yes to proceed
with the installation.

Figure 4. Windows user account control

The installation wizard can be run without deinstalling an existing installation. In this
way, for example, a broken installation can be fixed or an earlier failed attempt can be
completed.
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Figure 5. Teo installation wizard

Note: Use Windows control panel to uninstall Teo.

6.1.1 Before installing the PC software for the TEA1905

• Leave the demo board disconnected for now.
• Leave UTC disconnected for now.

Driver packages for UTC are installed. When UTC is plugged into one of the USB ports
for the first time, the drivers are installed automatically.
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6.1.2 Installing the PC software

• While installing the PC software, leave UTC disconnected.
• Run the installer wizard “Install_Teo_x_y_z.exe”. X, y, and z indicate the version

number of Teo.
• Follow the instructions of the installer wizard.

During installation, you may be asked to trust the software publisher twice. Confirm with
Yes to continue the driver package installation.

A progress dialog appears while the driver packages are installed.

Most likely, the software is installed and ready to use instantaneously. However, in some
cases a reboot is required. If a reboot is required, a message is shown. In that case,
reboot your PC to finish the installation.

6.2 User interface

Teo has a number of tabbed pages, each with a number of controls. The pages Basic,
Advanced, and Protection, show the contents of the MTP memory of the TEA190x.

These controls visualize the parameters of the settings of the device. They allow the user
to modify their values. Some parameters are specific for certain devices. So, the layout
may vary per device and differ from the screenshots in this document.

A fifth tabbed page is reserved for UTC.

Figure 6. Settings

The Basic page contains the definition of seven PDOs and a number of hardware and
software configuration settings. See the TEA190x data sheets for an explanation of these
settings.

Figure 7. Basic tab: PDOs
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If UTC is connected, live data is shown at the bottom of the Basic page.

The actual Vbus voltage and current measured by UTC and the firmware version of the
device are shown. The Soft Restart button reboots the demo board.

For more details on UTC, see Section 6.6.

Figure 8. Voltage and current

The Protection page contains all settings that deal with protection against high
temperatures, overvoltage, undervoltage, and overcurrent.

Figure 9. Protection page

The Advanced page contains less frequently changed settings and settings that require a
thorough understanding of their purpose. The settings that deal with the discharge curve
are grouped in a separate box. For more details, see the TEA190x data sheets.
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Figure 10. Advanced page

The Extended SrcCaps page contains parameters that deal with USB-PD 3 extended
source capabilities. This page is only visible if USB-PD 3 compatibility is enabled on the
Basic page.

Figure 11. Extended SrcCaps page
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6.3 Connecting Teo to the demo board

Teo can read and update the configuration of the TEA190x on the demo board. The
configuration is stored in MTP memory. The MTP memory is accessible via the type-C
receptacle and vendor defined messages (VDM). For more information on MTP memory,
see Section 6.4.2, and Section 6.4.

To read and write MTP memory, Teo requires UTC in sink mode and a PD contract
between UTC and the demo board.

At start-up, Teo looks for UTC and initializes the connection if one is found. If UTC is
unavailable at start-up, the Sink and Sniffer page are hidden and the UTC controls are
disabled.

Whenever a USB device is inserted or removed, Teo automatically scans for known
hardware interfaces. Optionally, Teo can be instructed to look for UTC and other
interfaces with the menu option: Options > Scan interfaces.

Figure 12. Menu option: Options > Scan interfaces

In addition to UTC, a few other interfaces are supported and may be available in
the Options > Interface menu. Support for Aardvark, FT201XM, FT232H, and two
hardwareless emulators are built in. The Hardwareless simulators are not real interfaces.
The only purpose of the simulators is to demonstrate the software without any external
hardware.

When an interface is ready to use, Teo attempts to communicate with the TEA190x. It
tries to set up a remote function call (RFC) protocol. If successful, Teo proceeds with
reading the MTP memory contents and updating the tabbed pages accordingly.

The status bar at the bottom of the main window of Teo shows information about the
current connection. The text in the status bar shows the name of the interface and
optionally, version information or serial numbers. The icon in the left corner shows a plug
and receptacle. If the two are connected, a valid connection has been set up and the
entire MTP memory is read. If a connection could not be established or reading of MTP
memory failed, the icon shows a disconnected plug and receptacle. During initialization of
the RFC protocol, the text "Initializing..." is shown. When reading the MTP memory, the
text "Reading settings…" is shown.



NXP Semiconductors UM11014
TEA190x evaluation overdrive (TEO)

UM11014 All information provided in this document is subject to legal disclaimers. © NXP B.V. 2018. All rights reserved.

User manual Rev. 2 — 16 November 2018
19 / 35

a. Connected

b. Communication error

c. Disconnected

Figure 13. Teo software: Status bar

Note: The TEA190x demo board must be powered on and UTC must have established a
PD contract before the MTP memory can be accessed.

6.4 Configuration

6.4.1 Configuring UTC for communication

To communicate with TEA190x, UTC must be in sink mode. If UTC is in sink mode, a
tabbed page Sink is visible. If UTC is in sniffer mode, a tabbed page Sniffer is visible. If
UTC is disconnected, the Sink and Sniffer pages are invisible.

To switch UTC from sniffer to sink mode, select Options > UTC > USB-PD sink from the
menu or press the Battery button on the toolbar.

 

 

When UTC connects to the PC, it always starts up in sniffer mode. In this way,
interference with a USB-PD sink that might be connected already is prevented.
Whenever it connects to the PC, Teo can automatically change UTC to sink mode. If
UTC is primarily used as a USB-PD sink, check the menu Options > UTC > Configure as
Sink on connect.
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Figure 14. Menu Options > UTC > Configure as Sink on connect

When UTC is in Sink mode, it negotiates a power contract with TEA190x automatically.
For more details about changing UTC settings in Sink mode, see Section 6.6.1. A power
contract is mandatory for communication between Teo and TEA190x. When a power
contract exists, Teo communicates with TEA190x through remote function calls (RFC)
over vendor defined messages (VDM).

Notes:

- In sniffer mode, UTC only listens to USB traffic and does not participate in
communication.

- Only one USB-PD sink at a time can be attached to a USB-PD source.

6.4.2 Reading the configuration

When Teo starts up and a TEA190x is connected, the MTP memory is read
automatically. You can manually read/reread the MTP memory, by choosing Options >
Read MTP. Teo always reads the entire MTP memory.

Figure 15. MTP progress
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Before the current configuration can be read from MTP memory, UTC requires a PD
contract. To negotiate a power contract with TEA190x, UTC must be configured as a
USB-PD sink. For more information on setting up a connection, see Section 6.4.1.

When MTP is read, a small progress dialog appears. If reading MTP is successful, the
dialog disappears. If MTP reading is unsuccessful, the dialog remains visible and shows
an error message. Close the dialog with the Close button.

When information is read from MTP memory, the controls on the tabbed pages are
updated to show the current configuration. For the meaning and purpose of individual
settings, see the TEA190x data sheets.

6.4.3 Viewing the configuration

The content of the MTP memory is shown with four different types of controls:

• Drop-down lists
• Check boxes
• Radio buttons
• Text entries

Unwritten changes appear with a blue type font. Values that differ from the default device
settings, appear with an italic type font.

a. Unwritten changes

b. Value differs from default

c. Value has changed, differs from default, and is unwritten

Figure 16. Viewing the MTP content

The default MTP values vary per device and package. When Teo reads MTP memory, it
determines the type and adjusts the user interface accordingly. The type is marked with a
check sign in the menu View > Chip type.

A different chip type can be chosen from the View > Chip type menu. That does not affect
the MTP values. However, it determines how the user interface behaves. The default
values may differ and some controls are disabled, enabled, hidden, or shown, depending
on the chosen type.
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Figure 17. Chip type menu

6.4.4 Changing the configuration

The content of the MTP memory is shown with four different types of controls:

• Drop-down lists
• Check boxes
• Radio buttons
• Text entries

When any of these values is changed, the changes are kept in the memory of the PC.
They are not automatically written to MTP memory. When the content of the text entry
fields has changed and the control loses focus or when Enter is pressed, the text entry
fields accept the new value. Teo finds the closest binary match that corresponds to the
entered value.

With the menu Options > Write to MTP, the F6 key, and the refresh button on the toolbar,
the changes can be written to MTP. When all changes are written, the MTP is read back
and compared with the values in memory. If updating the MTP was successful, the read
values equal the values in memory and the recent changes no longer appear in blue.

Although the changes are written to MTP, the configuration is not updated
instantaneously. The changes are only effective after a soft restart. The Soft Restart
button can be found at the bottom of the Basic page.

To change MTP memory, a valid connection is required. For more information on
establishing such a connection, see Section 6.3.
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6.5 Memory initialization file (*.mif)

MIF files are ASCII files, describing the layout and contents of memory. The MTP
contents can be stored in and updated from MIF files.

The menu File > Store in MIF… saves all current MTP values from the memory of the PC
to a file in MIF format.

The menu File > Load from MIF… reads MTP values from a MIF file into the memory of
the PC.

To save the contents of MTP memory of TEA190x, connect the demo board to Teo
and read its MTP. See Section 6.4 for details on reading MTP. When the entire MTP
memory is successfully read, choose File > Store in MIF… Enter a file path in the Save
File dialog.

To update the contents of MTP memory from a MIF file, connect the demo board to Teo
and read its MTP. See Section 6.4 for details on reading MTP. When the entire MTP
memory is successfully read, choose File > Load from MIF… Select a MIF file path with
the Open File dialog. The contents of the file is shown in Teo. Changed values, values
from the MIF file that differ from the MTP values, appear in blue. Review the changes. To
write the changes to the demo board, choose Options > Write to MTP from the menu.

Note: The first 12 addresses contain calibration data. They are specific to individual
devices. Those 12 pages are never updated as it would decrease the performance of the
device.
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6.6 USB-PD monitor

Teo works with two types of data regarding USB-PD, USB-PD messages, and bus
voltage and current. To handle this data, Teo uses UTC as interface.

When UTC is connected, Teo reads the bus voltage and the current a number of times
per second. The bus voltage, the current, and the CC voltages are shown in the signal
monitor. They can be saved to disk (see Section 6.7).

UTC works in two exclusive modes, which can be selected from the Options menu:

• Sink mode
• Sniffer mode

The UTC mode can also be changed with two toolbar buttons:

Toolbar button Description

Ear button:
For switching UTC to sniffer mode

Battery button
For switching UTC to sink mode

6.6.1 Sink mode

In sink mode, UTC acts as a USB-PD sink. It sends information, like the sink state and
PD messages received from TEA190x, to Teo.

Five control options are available from the Sink tabbed page:

• RDO
• Soft reset
• Hard reset
• Vsafe after detach
• Repeat RDO (ms)

The settings in the RDO box influence the power contract UTC negotiates. With the PDO
nr dropdown box, an explicit PDO can be chosen. If Auto is selected, UTC chooses the
closest match, with a preference for PPS PDOs. The contract is negotiated on the first
available moment, either immediately, or on the next attach.
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Figure 18. UTC - Sink page

To have UTC send a soft reset request to the TEA190x, click the Soft reset button. The
result in terms of state and the corresponding messages appear in the bottom list. The
Hard reset button sends a hard reset request.

Messages from the USB-PD source are shown in a raw format. To see more details,
hover the mouse pointer over the information icon in the first column. A popped up tooltip
shows decoded details off the message.

The second column shows the lapsed time between the message or state change and
the previous line.

If the box Vsafe after detach is checked, the voltage request automatically changes to
5 V when a detach is detected.

Figure 19. Decoded message

The box Source capabilities shows up to seven PDOs. The voltage and current of the
PDOs are decoded from the TEA190x messages. Clicking a PDO changes the voltage
request in line with the selected PDO.

Note: UTC prefers PPS PDOs. So, the result may be a different PDO, but with the same
voltage.
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Devices with PPS optionally use a watch dog timer. If the timer expires, the power
contract is lost. To restart the timer and prevent contract loss, the sink must resend
the last RDO. To have Teo resend the current RDO automatically, enter an interval in
milliseconds in the box Repeat RDO (ms). The interval is ignored for fixed PDOs.

Note: Assuming UTC is connected to a TEA190x, the PDOs are the same as the ones
stored in the MTP memory of that same TEA190x. They can be viewed and edited on the
Basic page of Teo.

The list of states and messages can be cleared with the Broom button on the toolbar or
with the menu Edit > Clear captured data.

Note: All captured data is cleared, including the graphs and the Sniffer page contents.

6.6.2 Sniffer mode

In sniffer mode, UTC only monitors Vbus and the CC lines. In other words, UTC is
invisible to USB_PD source and sink. One type-C connector of the UTC connects to the
TEA190x, the other to a USB-PD sink. Figure 20 shows how UTC is located between a
USBPD sink and a TEA190x adapter.

Figure 20. Sniffer mode connections

UTC monitors the traffic between the two devices and sends the decoded protocol
messages to Teo. The data messages and control messages are shown in a list on
the Sniffer page. Data is shown in hexadecimal format. The time (ms) between two
messages is shown in the second column.
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Figure 21. Data message and control messages

When a decoded representation of a message is available, the first column contains
information icons. Hovering the mouse over such an icon reveals details in human
readable format.

Figure 22. Sniffer information

The list of messages can be cleared with the Broom button on the toolbar or with the
menu Edit > Clear captured data.

Note: All captured data is cleared, including the graphs and the Sink page contents.
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6.7 Signal monitor

The Signal monitor shows the Vbus voltage, the Vbus current, the CC1 voltage, and the
CC2 voltage as a function of time. To make the Signal monitor window visible, check the
View > Signal monitor menu or press F9.

Note: The menu option is only available when UTC is connected.

If supported by the device, the Vbus current, die temperature, and the NTC temperatures
are plotted as well. These values are measured by TEA190x and read via VDMs from the
device.

Figure 23. Signal monitor

The graphs update a few times per second as new data is read from UTC.

The buttons on the toolbar have the following functions:
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Table 2. Toolbar buttons
Toolbar button Description

Pause:
Causes the graphs to stop updating, while data capturing is continuous. The
graphs remain ‘frozen’ until the Pause button is clicked again.

Clear:
Wipes the graphs and all captured data.

Time scale:
Choose the scale of the graphs as the time per division.

Auto zoom:
To improve the graphs resolution, the graphs automatically adjust the vertical
range.

Note: Clearing the graphs deletes all captured data, including the contents of the Sink
page and Sniffer page.

6.8 Firmware

6.8.1 Device firmware

The TEA190x has onboard RAM and ROM. It can use an external EEPROM. After
power-on, a firmware image is read from the EEPROM and executed in RAM. If no
firmware is available, the default image from ROM is executed. Teo allows replacing an
image in the EEPROM or loading and executing an image directly in RAM. Generally,
EEPROM images have the file extension *.bin. RAM images have the extension *.cde.

Before attempting to load new firmware, make sure that Teo is connected to the
TEA190x. To see if a valid connection is present, check the status bar at the bottom of
the main window of Teo.

To replace the firmware image in EEPROM, choose File > Firmware from the menu
or click the firmware button on the toolbar. Browse to the firmware image file and click
Open. A dialog window with a progress indicator appears. The image is written to the
EEPROM. When the EEPROM is updated, Teo verifies the content to ensure that the
image has been written correctly.

Note: The new image is loaded the next time the TEA190x is powered up.

Figure 24. Uploading firmware
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To load an image directly in RAM, choose File > Firmware from the menu or click the
firmware button on the toolbar. Select Files of type > RAM image. Browse to the desired
firmware image file and click Open.

Figure 25. File selection dialog

A dialog window with a progress indicator appears. The image is written to RAM. A
running CRC check verifies that the image is loaded without errors. If the entire image
is successfully loaded in RAM, the new image is executed immediately without power
cycling the TEA190x.

The firmware of TEA1903 devices and TEA1905 in an SO14 package cannot be written
to EEPROM with UTC. To receive an I2C interface and additional instructions to update
the EEPROM, contact the local service team of NXP Semiconductors.

6.8.2 UTC firmware

Teo embeds the latest UTC firmware. If Teo connects to a UTC with outdated firmware,
an upgrade option is presented.

Figure 26. Incompatible UTC - upgrade option

To have Teo benefit from new UTC features and other improvements, always upgrade
UTC to the latest version.

Teo advises to upgrade once per session. Upgrading UTC can be chosen at any time
from the Options > UTC > Upgrade UTC firmware menu.

To be able to upgrade UTC, UTC must be connected to the PC with a USB-OTG cable.
UTC recognizes the OTG cable and boots in DFU mode. Teo shows the following dialog:
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Figure 27. UTC upgrade option - connection

When the outdated UTC is connected to a USB port with an OTG cable, press OK.

During the upgrade, the flash memory of UTC is erased, written, read back, and
compared to verify success. These steps and their progress are shown in the Upgrading
UTC dialog.

Figure 28. Upgrading UTC
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6.9 Toolbar

The toolbar contains several buttons. Here is a short explanation of their function:

Table 3. Toolbar buttons
Toolbar button Description

Write changes to MTP

load an image to RAM or EEPROM

save captured data in Comma-Separated Values (CSV) format

show or hide the signal monitor window

clear captured data

clipboard functions: Cut, Copy, and Paste

opens the user manual

puts UTC in sniffer mode

puts UTC in sink mode
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7 Abbreviations
Table 4. Abbreviations
Acronym Description

DFU device firmware upgrade

EEPROM electrically erasable programmable read-only memory

MIF memory initialization file

MTP multiple times programmable

OTG on-the-go

PDO power data object

RAM random-access memory

ROM read-only memory

Teo TEA190x evaluation overdrive

USB universal serial bus



NXP Semiconductors UM11014
TEA190x evaluation overdrive (TEO)

UM11014 All information provided in this document is subject to legal disclaimers. © NXP B.V. 2018. All rights reserved.

User manual Rev. 2 — 16 November 2018
34 / 35

8 Legal information

8.1  Definitions
Draft — The document is a draft version only. The content is still under
internal review and subject to formal approval, which may result in
modifications or additions. NXP Semiconductors does not give any
representations or warranties as to the accuracy or completeness of
information included herein and shall have no liability for the consequences
of use of such information.

8.2  Disclaimers
Limited warranty and liability — Information in this document is believed
to be accurate and reliable. However, NXP Semiconductors does not
give any representations or warranties, expressed or implied, as to the
accuracy or completeness of such information and shall have no liability
for the consequences of use of such information. NXP Semiconductors
takes no responsibility for the content in this document if provided by an
information source outside of NXP Semiconductors. In no event shall NXP
Semiconductors be liable for any indirect, incidental, punitive, special or
consequential damages (including - without limitation - lost profits, lost
savings, business interruption, costs related to the removal or replacement
of any products or rework charges) whether or not such damages are based
on tort (including negligence), warranty, breach of contract or any other
legal theory. Notwithstanding any damages that customer might incur for
any reason whatsoever, NXP Semiconductors’ aggregate and cumulative
liability towards customer for the products described herein shall be limited
in accordance with the Terms and conditions of commercial sale of NXP
Semiconductors.

Right to make changes — NXP Semiconductors reserves the right to
make changes to information published in this document, including without
limitation specifications and product descriptions, at any time and without
notice. This document supersedes and replaces all information supplied prior
to the publication hereof.

Suitability for use — NXP Semiconductors products are not designed,
authorized or warranted to be suitable for use in life support, life-critical or
safety-critical systems or equipment, nor in applications where failure or
malfunction of an NXP Semiconductors product can reasonably be expected
to result in personal injury, death or severe property or environmental
damage. NXP Semiconductors and its suppliers accept no liability for
inclusion and/or use of NXP Semiconductors products in such equipment or
applications and therefore such inclusion and/or use is at the customer’s own
risk.

Applications — Applications that are described herein for any of these
products are for illustrative purposes only. NXP Semiconductors makes
no representation or warranty that such applications will be suitable
for the specified use without further testing or modification. Customers
are responsible for the design and operation of their applications and
products using NXP Semiconductors products, and NXP Semiconductors
accepts no liability for any assistance with applications or customer product
design. It is customer’s sole responsibility to determine whether the NXP
Semiconductors product is suitable and fit for the customer’s applications
and products planned, as well as for the planned application and use of
customer’s third party customer(s). Customers should provide appropriate
design and operating safeguards to minimize the risks associated with
their applications and products. NXP Semiconductors does not accept any
liability related to any default, damage, costs or problem which is based
on any weakness or default in the customer’s applications or products, or
the application or use by customer’s third party customer(s). Customer is
responsible for doing all necessary testing for the customer’s applications
and products using NXP Semiconductors products in order to avoid a

default of the applications and the products or of the application or use by
customer’s third party customer(s). NXP does not accept any liability in this
respect.

Export control — This document as well as the item(s) described herein
may be subject to export control regulations. Export might require a prior
authorization from competent authorities.

Evaluation products — This product is provided on an “as is” and “with all
faults” basis for evaluation purposes only. NXP Semiconductors, its affiliates
and their suppliers expressly disclaim all warranties, whether express,
implied or statutory, including but not limited to the implied warranties of
non-infringement, merchantability and fitness for a particular purpose. The
entire risk as to the quality, or arising out of the use or performance, of this
product remains with customer. In no event shall NXP Semiconductors, its
affiliates or their suppliers be liable to customer for any special, indirect,
consequential, punitive or incidental damages (including without limitation
damages for loss of business, business interruption, loss of use, loss of
data or information, and the like) arising out the use of or inability to use
the product, whether or not based on tort (including negligence), strict
liability, breach of contract, breach of warranty or any other theory, even if
advised of the possibility of such damages. Notwithstanding any damages
that customer might incur for any reason whatsoever (including without
limitation, all damages referenced above and all direct or general damages),
the entire liability of NXP Semiconductors, its affiliates and their suppliers
and customer’s exclusive remedy for all of the foregoing shall be limited to
actual damages incurred by customer based on reasonable reliance up to
the greater of the amount actually paid by customer for the product or five
dollars (US$5.00). The foregoing limitations, exclusions and disclaimers
shall apply to the maximum extent permitted by applicable law, even if any
remedy fails of its essential purpose.

Safety of high-voltage evaluation products — The non-insulated high
voltages that are present when operating this product, constitute a risk of
electric shock, personal injury, death and/or ignition of fire. This product is
intended for evaluation purposes only. It shall be operated in a designated
test area by personnel that is qualified according to local requirements
and labor laws to work with non-insulated mains voltages and high-voltage
circuits. The product does not comply with IEC 60950 based national or
regional safety standards. NXP Semiconductors does not accept any liability
for damages incurred due to inappropriate use of this product or related to
non-insulated high voltages. Any use of this product is at customer’s own
risk and liability. The customer shall fully indemnify and hold harmless NXP
Semiconductors from any liability, damages and claims resulting from the
use of the product.

Translations — A non-English (translated) version of a document is for
reference only. The English version shall prevail in case of any discrepancy
between the translated and English versions.

Security  — While NXP Semiconductors has implemented advanced
security features, all products may be subject to unidentified vulnerabilities.
Customers are responsible for the design and operation of their applications
and products to reduce the effect of these vulnerabilities on customer’s
applications and products, and NXP Semiconductors accepts no liability for
any vulnerability that is discovered. Customers should implement appropriate
design and operating safeguards to minimize the risks associated with their
applications and products.

8.3  Trademarks
Notice: All referenced brands, product names, service names and
trademarks are the property of their respective owners.

GreenChip — is a trademark of NXP B.V.
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